Startseite > Dokumentation > Opensource > Debian - Updates für OwnCloud wegen veralteter PGP Key Datei nicht möglich
 
 
 
 

Debian - Updates für OwnCloud wegen veralteter PGP Key Datei nicht möglich


Beschreibung

diese Kurzbeschreibung soll die Schritte darstellen, wie Sie folgendes Fehlerbild beheben können.
 
Eine Debian 8 Installation, meldet beim versuch via apt-get update, dass ein Update wegen einer abgelaufenen PGP Key Version für OwnCloud nicht durchgeführt werden kann.
 
OwnCloud Update Error - apt-get update kann nicht durchgeführt werden
Bild zur Vergrößerung anklicken ...
 
 
Schritte:
  1. Melden Sie sich als Root am System an.
  2. Navigieren Sie in das tmp Verzeichnis via: cd /tmp
  3. Beziehen Sie den für die installierte OwnCloud Version, in diesem Fall Nr. 8, den aktuellen PGP Key:

    wget -nv https://download.owncloud.org/download/repositories/production/Debian_8.0/Release.key -O Release.key


  4. Fügen Sie den bezogenen Key hinzu: apt-key add - < Release.key
  5. Hinterlegen Sie die aktuelle Repository Liste:

    echo 'deb http://download.owncloud.org/download/repositories/production/Debian_8.0/ /' > /etc/apt/sources.list.d/owncloud.list


  6. Führen Sie anschließend ein Updateversuch durch: apt-get update
 
 
Wenn Sie die oben genannten Schritte durchgeführt haben, ist ein Update des Systems wieder möglich.
 
 
Möglicher Stolperstein: Beim Updateversuch könnte folgende Fehlermeldung auftretten:
W: Duplicate sources.list entry http://download.owncloud.org/download/repositories/stable/Debian_8.0/  Packages (/var/lib/apt/lists/download.owncloud.org_download_repositories_stable_Debian%5f8.0_Packages)
W: Probieren Sie »apt-get update«, um diese Probleme zu korrigieren.
 
UMSETZUNG auf eigene Gefahr: Leeren Sie den Inhalt des Lists Verzeichisses: rm /var/lib/apt/lists/*